Path must be a string.

问题如下:

![]()

问题的原因:

umi插件版本与umi的版本有冲突,现在直接使用命令安装umi的话,系统都会默认给你安装最新版umi3,而umi3已经对原来的插件进行了更新,所以如果你的umi是最新版的,就要参考官方文档最新版的配置方式,不能一味地使用原来的配置,否则会一直报错。

解决办法:

需要先执行

tyarn remove umi-plugin-react --dev

将umi-plugin-react卸载,

再执行

tyarn add @umijs/preset-react --dev

然后可以看到此时在package.json文件中,已经变为@umijs/preset-react

![]()

然后在config.js文件中修改

将原来的:

![]()

现在改成这样:

// 导出一个对象,暂时设置为空对象,后面再填充内容
export default {

    dva:{},
    antd:{},
}; 

安装新的插件

官网的解决办法

声明:该文章系转载,转载该文章的目的在于更广泛的传递信息,并不代表本网站赞同其观点,文章内容仅供参考。

本站是一个个人学习和交流平台,网站上部分文章为网站管理员和网友从相关媒体转载而来,并不用于任何商业目的,内容为作者个人观点, 并不代表本网站赞同其观点和对其真实性负责。

我们已经尽可能的对作者和来源进行了通告,但是可能由于能力有限或疏忽,导致作者和来源有误,亦可能您并不期望您的作品在我们的网站上发布。我们为这些问题向您致歉,如果您在我站上发现此类问题,请及时联系我们,我们将根据您的要求,立即更正或者删除有关内容。本站拥有对此声明的最终解释权。